New Install - OpenRPA crashing Windows 11 Pro

When I launch it spins for a second then nothing. Here is the log from the Event Viewer.

Faulting application name: OpenRPA.exe, version:, time stamp: 0xdb47fba2
Faulting module name: ucrtbase.dll, version: 10.0.22621.3593, time stamp: 0x10c46e71
Exception code: 0xc0000409
Fault offset: 0x000000000007f6fe
Faulting process id: 0x0x3B24
Faulting application start time: 0x0x1DABB78176F766B
Faulting application path: C:\Program Files\OpenRPA\OpenRPA.exe
Faulting module path: C:\Windows\System32\ucrtbase.dll
Report Id: 5184e55e-41c4-4d03-9728-b58ded93de80
Faulting package full name:
Faulting package-relative application ID:

1 Like

I faced the same issue and couldn’t find a proper solution despite trying various suggestions from forums and AI tools. Ultimately, I installed the previous version (, which works fine. So, I’m currently using the version

Sorry to hear you both had that issue.
If one of you have the time and option too; It would be really helpful if you could get me a memory dump.

  • Simply add the registry keys from below guide,
  • Start OpenRPA
  • Zip and upload the dump file somewhere and share the link with me
  • And then remove the registry keys and restart the computer to disable automatic memory dumps again
1 Like

Hi Allan,

Thank you for the quick response. I had created a memory dump as per the instructions and sent it to you on the chat. Please let me know if any more information is needed from my side.

Your support on this matter is truly appreciated. Thank you.

This is strange.
The error comes here

This is a know issue, when you have an UNSUPPORTED python in path, and is NOT using python embedded.
But the stack traces show you are using python embedded ( I’m assuming this is a fresh install ? )

We can also confirm that, based on the path trying to be registered is
This folder gets populated by the python.included@ package

I don’t really know how to process from this.
I cannot reproduce it, and i have no way of “debugging” what is going inside PythonEngine ( from Python.Runtime@
Googling python + ucrtbase gives a ton of stackoverflow and github post about people having issues with this.
I think this and this is the closest i gotten to an explanation. python requires c++ runtime to be installed, and on windows 11 this is bundled into the OS and somehow that makes python crash on certain version (???) but that does not explain why it does not crash on my windows 11 then, so i don’t feel i’m closer to a solution or work around.
I keept python at 3.7.3 solely to avoid these issues, so super anying microsoft then does something that breaks it.

So, does openrpa with python embedded 3.11.4 work on these windows 11 machines or where you using the ?
if 3.11.4 works on windows 11, could you the installer with 3.11.4 for OpenRPA i just uploaded

Hello Allan,

Thanks for the reply. For installing V, I was using the OpenRPA.msi itself and not the

Additionally, I had just tried on the installer for you have just provided and it works perfectly fine for me.

thanks for the information.
I have updated the to include a message about windows 11, can try the 3.11.4 version.

1 Like

Thank you for the prompt response and solution on this matter. Looking forward to working more with OpenRPA.

1 Like

I had a newer version of Python 3.11.8. I uninstalled and downgraded to 3.11.4 and then tried the After doing I still am not able to get OpenRPA to launch, and now the Event Viewer doesn’t show errors. I also tried to produce a dump file with no success. I am not sure what to do, I may downgrade even further to Python 3.7 or something

When OpenRPA is set for “embedded python” ( the default )
it should not matter if you have python installed and/or what version.
In the dump created by JithinKrishnan, the issue was windows 11’s builtin c++ runtime giving issues. If you issue is different it would be nice if you could create a memory dump.

If you have successfully imported the reg file, windows will create a file in c:\Dumps everytime any process is killed by an unhandled exception ( that is why it’s important to remove the setting once done, or it will fill your hard drive pretty quickly )
if no dump is created, check if openrpa is still running ?
if not, then please run regedit and manually check the settings have been successfully created.
if yes, OpenRPA is still running, then open task manager, there should be an option to create a memory dump, if you send that, there might be a chance i can see what it was doing when you killed it.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.