How to automate file upload

Hi Peeps,


Again for Quickbooks Online, I can’t seem to click it’s upload button, not even the input field or its surrounding web element … seems it’s a layer on top of the core, but OpenRPA simply can’t do simulated clicking to open the file uploader to type in the file path … hope someone can assist :pray:

Massive thanks,

It’s a browser security issue, not an OpenRPA issue.
They will not allow javascript to trigger an upload, so you need to set “virtual” to false on the element click, that is used to click the upload button.

On certain browser versions, this will BLOCK the browser, so the extension will stop working while the “select file to upload” dialog is open. If that is the case for you, you will need to use a separate workflow to handle the file upload dialog. There is several posts on the forum about that, you can search for.

1 Like

Already set “virtual click” to false, the select file to upload isn’t showing up yet :frowning:

And is it actually clicking the right place ? did it move the mouse to that point ?

Actually, I’m not seeing the mouse while navigating :frowning: … any way to force to see the mouse pointer please?

Wait sir … checking on somethings … via recording might help …

Yey! Praise Jesus!

Working already … had to use the recording and set virtual click to false …

Massive thanks @Allan_Zimmermann :pray::slightly_smiling_face::+1:

HI @Allan_Zimmermann ,


One thing I observe, once we use the recording, OpenRPA becomes dependent on the image or exact screen location of the browse button, and when I move or resize the browser the clicking of the button fails because of the different screen position. I tried without recording, hence no dependency on the exact screen location but the web element can’t seem to be located.

Any assistance will be much appreciated regarding this matter.

Massive thanks :pray:

Hope someone can assist :pray:

Can you show how exactly you click the mouse? Screen recording uses exactly the same elements that can be manually dragged into the process from the elements panel, and it is strange that in the case of recording you have a dependency on the image, and in the other case you do not.

With that being said, I think you just don’t have the right selector, I’d like to take a look at it. Ideally, it would be better to send the full text of the selector

1 Like
  • When using image recognition, OpenRPA saves the process name. When running, it grabs all windows and searches for the image relative to the top left corner of the window(s).

  • If you click “process limit”, you also “lock” in a specific search area on the desktop (screen). This means if the window moves and the area you are interested in is not within the “process limit” area, then it will stop working. So, if this is set, press “Clear process limit” to avoid this.

  • If you remove the value in “process name”, it will search the entire desktop. This can be very CPU intensive and will take longer than searching within only a window of an application. If the application is maximized, it’s almost the same thing anyway, and then there would be no benefit to use process name.

So either way, clearing “process limit” and removing “process name” is always the first thing to test, when troubleshooting image.Get Element

1 Like

Hi @Velinkton and @Allan_Zimmermann


Sorry for my late reply. My basis on why I said that the Get Element is using image as basis was because when I use the recording, an image is suddenly added within the Get Element activity, compared to when I simply and manually configure the Get Element.

For an hour a moment ago I tried to experiment on the x and y offset, and sure enough, those numbers are the numbers that sets the point as to where the mouse clicking occurs, as I turn on the animation to see where mouse pointer clicks, after experimenting the size and position of the Chrome browser itself were adjusted.

And I would assume those numbers will differ on different screen resolutions :slightly_smiling_face::+1:

So for me, issue resolved and many thanks for your assistance :pray:


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.