First installation - after starting OpenRPA, nothing happens

Hello,

I installed OpenRPA and tried to run, but nothing happens. I noticed 3 warnings and 1 error in event viewer.

First warning:

Error:


error1-status

Second warning:

Third warning

I’m pretty sure all of those are unrealted to openrpa.
But there is a “bug” going around that makes openrpa crash on SOME windows 11 machines, related to python
on the download page there are 2 version of openrpa with different version of openrpa, please try the other one

or, you can try to edit the config doing install and de-select “scripts” ( that is the one using python )

I saw topic with a Python issue and tried this OpenRPA.py.3.11.4.msi but still nothing. I also tried previous versions - currently I have installed 1.4.56.

I also tried installing for all users and for a specific user, but it doesn’t change anything.

When I run it as admin, I get 1 warning:

please run the installer and remove scripting support ( python )

image

if it still crashes doing launch, then please follow this guide on how to enable crash dumps, and then upload it to google drive so i can maybe see what it’s crashing ( this must be done with latest version of OpenRPA or the symbols will not match with my source code )

just a FYI … I have added your user to the company at app.openiap.io and made you admin. In case you later need to share workflows with others.

I used again the newest version and removed scripting support. Now it works, thanks.

1 Like

Looks like i need to create a version of OpenRPA with python scripting as a separate component. It’s the only thing that has been giving problems the last few years …
Thank you for the feedback, and glad you now has a solution.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.

I have update the OpenRPA installer to not install scripts component by default.
This should avoid others to have the same issue ( unless the decided to install scripts and it’s incompatible )
I will see if i can extract the python part and make it a separate package at some point, so people who needs scripting but not python can get that

2 Likes