Disabling agents

I encountered a problem that my NodeRED agents began to disconnect, going into the “missing” status. This began to happen recently when the number of agents increased from 3 to 8 in one day. I couldn’t track how long they work, but it feels like they work for 1-2 days and then turn off

At first I thought that the Linux server did not have enough resources. I added RAM and allocated 2 cores for the processor, but the situation has not changed

What could be causing this problem?

Dedicated agents disconnected themselves

Hmm, is it the same one’s that die every time ?
is the one the dies “new” or does the one of the original 3 also die ?

Do you see any errors that could cause a crash in the logs ?
( list all dockers and find one of those not running then do get the logs using the id )

docker ps -a
docker logs <ID>

Any agent can stop working, both old and new ones that I added recently. The key here is that this started happening when I added 5 new agents, but I’m not sure if the problem is directly related to this

But it was not possible to get logs of fallen containers, since they are not displayed at all in the list.

Then they where deleted, not stopped.
Most likely that is openflow then, does it happen every 8 hour by any chance ?

If so, it could be the housekeeping job, that among many things also removed agents that has been running for more than 8 hours and does not have the billing tag.
This feature is enabled if you have enabled multi tenancy and/or have created a “agent” resource ( so you can select between free and other sizes when creating an agent )



Yes, I created this resource on February 12th. And on the same day problems began with the agents. I created a resource using the ensurecommon button (I was just studying the possibilities of OpenFlow in my free time).

I deleted the resource and when creating an agent I can no longer choose a paid plan. I’ll be monitoring the agents’ behavior for a couple of days. I will post the results in this topic

No, create the resources, and then assign a plan to all agents.
( you need to select a plan and click save, and then stop/start the agent to “tag” it )

Returned the resource back, set the free plan, clicked save, and restarted the agents

It turns out that after such manipulations the housekeeping job will not disable my agents every 8 hours?

No set them to a NON free plan … or they will get removed after 8 hours ;-D
just like on app.openiap.io

Okay, I understand :smiley:
Thanks for the help

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.