What happened to breakpoint?


I tried to catch an item activated by “click” and assign a value to it.

I set a breakpoint for that on “Assign” activity, which has been omitted and workflow ended with error. “Assign” should activate search “blue box”, which not happened.

It seems, that “Assign” related to the preceding win.Get_Element has not been run.

What I am doing wrong?

All activities are in the same sequence, so that see the same item.
This combination works as separated, small workflow (except necessity of the some activity selector refresh…).

Kind regards,

It means Get element did not find anything.

Another hint. workflow foundation will not “show” then item variable if you are not in an activity, so while debugging, make sure the thing inside get element is in a sequence …
( Just drag ANY activity below the assign activity, it will auto add an “outer” activity, and you can then remove the “ekstra” activity you dragged in )

Hi Allan,

Regarding hint.
That was my idea. I intended to see variables (item) created by “SecondFace of Search” and that is the reason of a breakpoint on the “Assign”, which is (classically) inside “SecondFace of Search” and all its variables should be for “assign” in the range of visibility.

It turned out, that “SecondFace of Search” gave no message about any problems, breakpoint did not fire and workflow stopped on the image.get_element as is it expected. This activity should search “blue square”, which would appears if “assign” worked correctly. Still in “Open File” window of the browser and win10. In win7 there is no problem as all components of this window are available “on screen” and are not “dynamic”.

Kind regards,

get element will only throw an error if minimum items is above 0.
If no elements was found, get element will not run what is in the body of the activity. ( as it runs one time per item found )

Thanks Allan! :wink:

Yes, indeed… It is all my fault.
Now it works…

Should I see “item” variable created by “Get Edit State of Search”?
When I run “assign”, it will set the field value as expected.

Kind regards,

you need to add the assign in a sequence to read item while debugging …

Hi Allan,

Now I understand it fully… I hope… :wink:

I assumed, that activity inside other “see” variables this “external”.
It turned out, that for that a “sequence” is a mandatory activity.

This exercise shows, how properly use breakpoint… :slight_smile:

It also shows, that both steps record different screen components. Maybe they are somehow related, as they both has common node (“ClassName”: “#32770”, “ControlType”: “Window”), but the second branch (“ClassName”: “HostedApplicationBase”) is not visible in the “Selector” tool.

I tried to assign value to the first item (ModernSearchBox), but I got error with message (more or less) “Operation on the component which has no proper factory”. It means, that item.value is to easy expression? Sorry, I do not know Windows UI libraries. The field value change I got from “RichEditBox”

I will try to attach both “selectors” as files.

Without that knowledge and/or Designer support, the Windows automation would be a real nightmare… :\

Moreover, I suffer from the “illness”, which I described in the separated thread “continuous selector refresh”. After restart all win.get_element will need to be “refreshed”. I do not suppose any product issues, maybe it is something on my side, but without discovery reasons it is a blocker for more wide presentation.

Kind regards,

ModernSearchBox.json (774 Bytes)
RichEditBox.json (1023 Bytes)

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.