Want to use OpenRPA + OpenFlow completely offline (without even being connected to the internet)

Dear Allan,

I have followed all your videos, to setup & changed all the settings required. Even followed these posts to create the local directory https://docs.openiap.io/docs/flow/Offline-Proxy-Server.html(https://docs.openiap.io/docs/flow/Offline-Proxy-Server.html).

Now if I open OpenFlow and RPA while being connected to the internet, then turn it off all’s good & changes in OpenRPA are reflected on the OpenFlow webpage and I can run the workflows from the Robot Workflows page.

The issue is if while I’m not connected to the internet and then try to freshly open the OpenFlow page itdoesn’t open, and even if I refresh it after initially opening it it doesn’t load. What I want to be able to do is completely be disconnected and access OpenRPA & OpenFlow.

Please advise, thank you

Its very complex to make it work offline, since both docker and npm requires internet to work by default.
I dont believe i made a guide. A customer once payed me to help them set it up, so I recorded a demo showing it can be done, shared together with example docker files. These files will not work without docker deamon being reconfigured.

Could you create a guide or short video if possible? or give some pointers as to how I can do it as its important for the project I’m working on.

I just re-read your first post, and I think i miss read your error.

you write

How did you “go off the internet” ? Docker and the machine you are testing from both need to have access to DNS, were you setup the 2 custom dns records.

Once that is working, you need to configure docker to use a local repository.
Then you need to ensure all packages have been loaded into verdaccio, and the you con configure NodeRED/npm to use verdaccio as default repository. the services.flows.json example flow, shows how to do that.

There is an issue thou, the new agent’s does not support that yet, so you will need to use one of the older nodered images that is not loaded using an agent ( openiap/nodered:old ) if you need agent’s to also work like that, feel free to reach out for a quote on me implementing that. ( right now that is not high on the priority list )

I did the offline install and used the offline-up.bat. Initially I am connected for the setup procedures, but after that i don’t want anything to be online because of security/privacy concerns. So bascially all I want is the OpenRPA & the OpenFlow page to be working together without any internet.

  • If all you want is to avoid openflow/openrpa to send statistics, just set “analytics” to false ( as explained here )
  • If you want to limit what places on the internet the installation can see, use a firewall that limits outgoing traffic, of for a “poor man’s” solution, just setup a dns server without the root server list.
  • if you truly need something that is completely without access to the internet, that is beyond what I will support for free over the forum. Can it be done, yes, but how heavily depends on the setup and requirements.

I have updated openflow and agent’s and the nodered package to accept a new environment variable called agent_NPM_REGISTRY
This will make the process of configuring agents as simple as setting this in docker compose/helms chart and then all packages will be installed using that.
So that leaves, DNS and docker repository

  • Most enterprises have internal DNS servers, so this should already be in place and working.
  • docker repository is tricky. Docker does NOT like using it self as repository, so if you can install a docker repository on a seperate server, then it’s as simple as updating the docker compose file to use the docker repository you setup … if not, then google how to make docker use a local docker repository … One of the tricks you need to handle is setting it up to using it self as cache.
    Personally i would not want to mess with that and simply create a separate server for hosting the docker repository

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.