Skype Element can not be caught

Hi guys, i’m doing the Window Automation workflow sample

At the step that use Record button to select skype app element. I clicked on this

When i run the workflow that element is not clicked and i get this error

I have tried select element manually in Selector window but it didn’t work. Is there a solution for this problem?

For Windows automation to work, there has to be some Windows Elements to find. Skype, MS Teams and several other apps are using Electron ( chrome wrapped in an separate executable ). To automate these, the developer needs to allow end users to enable Accessibility in chrome. Some electron apps will detect it and prompt you, like VS Code others have command lice switches to do this ( some use the chrome name --force-renderer-accessibility ) … and others again does not allow it at all. If none of those are an option you have to revert back to using image recognition.

Hi @Allan_Zimmermann, where can i find the image recognition in OpenRPA?

Under OpenRPA image.
There are several videos about that on youtube

1 Like