Send Output is not working


I have followed the following video guide to install my instance of openrpa/openflow/nodered.

I have followed along exactly with the following guide to send output to my nodered instance, and i cannot get it to work.

Any advice or common issues that i could look at?

Many thanks,

to provide some more detail: I am getting messages in my node red debug window, but it is just the message from the function node. So, it says, “hi mom 1” instead of “hi mom 1 one time” like in the posted video.

please show a screenshot of your flow

There are 3 “out”'s of the rpa node.
Top one gets activated when the workflow completes successful, bottom one if the workflow fails, middle one is for status messages.

Thanks, Al. I have added the two success and fail debug nodes and i am still getting the same result:

So what is the problem ?
I’m seeing output as the last message in your screenshot, so assuming you are getting that too.

The issue is that the msg.payload is only text from the function node, it does not have the text part from the rpa workflow output.

In other words, if i remove the function node, then I get no text in the msg.payload.

I have toggled the “send output” button in OpenRPA on and off and always get the same result.

Thanks for your help here!

Again, the output is in the last message

Shouldn’t I see output from the OpenRPA bot writeline? If I remove the function node I get no text at all in the msg.payload, just “data: undefined”.

In the “Function” node you create a message that will be sent to your robot. Regardless of its content, the robot starts when it receives a message. Since you don’t process this message in any way, it simply goes to the “Success” output of the robot and ends up in “Debug”.

To send some results from the robot to Node-Red, you need to at least create an Out-argument that will contain some value. I can’t say how to make it appear in the message payload, I’ve never tried it. But I’m sure it’s not difficult

There might also be a timing issue.
If the workflow runs to fast, the console output not be “cought” as being part of the workflow.
So adding a delay of 0:0:0.500 at the end might help

Thanks again for all of your responses and help.

I have simplified the flow to just writeline “hello world” and then added a 5 sec delay. No luck still. So, i took a step back and noticed that i am not getting any output into the console field in open flow. Shouldn’t i expect “hello world” there?

Many Thanks!

Thanks for this suggestion! I noticed i am not getting output into the console field in openflow when I look at the results from Entities > openrpa_instances. I am going to work on resolving this first, and then i will circle back to getting the writeline output into node red.


No. you did not enable that.
“save output” is adding the output to the instance i openrpa_instaces
“send output” sends the output as status messages to the one requesting the workflow run.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.