Problems with encoding when unzipping files


When I try to unzip a zip file using the “ExpandArchive” block, as a result, the encoding of the files gets lost. I tried using the “System.IO.Compression.ZipFile.ExtractToDirectory” function with the encoding in the parameter, but got the same result. I tried to unpack the archive with both Cyrillic and Latin characters - the result is always the same

How can I fix this?

I do the same, as you can see

If you can easily test, maybe test if this solves the issue ?



Unfortunately, it did not help me, although this time the characters are different

Try some more variations …
maybe this

SP866 encoding helped. I do not understand why other encodings containing Cyrillic characters could not process my file

Thank you very much!

Thank you for the feedback.
I will see if I can add an option to the two archive activities for setting this, but for now I’m glad you have a solution.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.