OpenRPA does not hit the checkbox any longer


we have a running Workflow. Used it often.
Since something has changed in the environment the openrpa-workflow does not hit the checkboxes (other links on the website are working are working). I asume, its a browserupdate.

if i click on “mark”, the missmatch is visible:
rpa does not hit the box

Playing around with windows-settings and setting a offset was not successful.

Browser is EDGE (117.0.2045.55).

OpenRPA and Browserplugin has been upgraded to the latest verions, that does not help.

kind regards

On some sites, some elements are not easy to interact with. In such cases, I changed the approach to interacting with the element.

I’ve never worked with flags, but if I were you, I tried to physically click on the element (if you use the “Click Element” activity). If this does not help, then you can try changing the element parameters on the page directly to add a flag (change the css class, etc.)

As @Velinkton mentioned.
By default OpenRPA will try and use javascript code to click things, in that case it’s only important it find it, not that it know were it is.
But if you for some reason decide to set Virtual to false, it will try and move the mouse to that location and click the element using a real mouse click.
There is a bug somewhere in my code that sometimes make OpenRPA unable to locate things precisely if you resize the browser or swap between minimized/maximized or if you change your DPI settings ( explained here )
OpenRPA does NOT support pages with framesets/iframes ( it mostly work when using virtal clicks but 99% of the time it cannot find the physical location of pages using that )

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.