Open RPA - Get element not able to capture few objects


I have installed open RPA, open flow & node red in windows machine, I tried to capture objects in an application and Get element is not able to detect few objects(for example : SSO login small window popup), also observing that open RPA is going into hanged time intermittently when trying to capture and when trying to update the commands.

Manoj Reddy

You need to give an example we can reproduce in order to help you,
or you need to give more information about what you are trying to do, what you have tried so far, and what type of errors you are getting, for us to have any chance of helping you.

Hi Allan,

For SSO authentication applications like service now we enter the email id to login and then there will be a small window popup to enter the username and password, with Get element command we are not able to capture that credentials window popup, Get element is not able to identify the popup due to which we are not able to proceed further.

Also intermittently observed that Open RPA is going into hanged state, any suggestion on how to fix?

Manoj Reddy


Attaching the application credentials popup screenshot.

That is not SSO, that is basic authentication.
And the problem with that, is it lock’s up the browser while the dialog is open, so the chrome extension cannot work with the browser.
You need to use windows automation to ( windows.get element ) to fillout that box.
And if you clicked something in the browser to open it, and the robot stall’s, you need to add your windows automation in a separate workflow and run it asynchronously

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.