Open “” , HPPT error 404

HTTP Error 404. The requested resource is not found.

run normal-up.bat, it is ok.

Docker image

Please help this error.


Can you please tell which docker file you are using to setup and system from which you are accessing Openflow and system where you have setup are same system?

I installed docker on Windows 11 using the normal-up.bat command.
docker compose -f docker-compose.yml -p demo up -d

which you are accessing Openflow and system where you have setup are same system?are both in same system or deferent?

yes sir,is same one system.

I am 99.999 percent sure you have some webserver blocking port 80
Stop docker, find what is using port 80 and stop it, then restart docker.

Let’s review the status of this issue:

When I installed normal-up.bat at before, the following error occurred:

“Error response from daemon: Ports are not available: exposing port TCP → listen tcp bind: An attempt was made to access a socket in a way forbidden by its access permissions.”

So I modified traefik port from 80 to 443 and ran normal-up.bat again. Everything seemed normal.

But when opening “”, an error occurs:

So I checked to see if any application was using port 80, but couldn’t find anything, except a system kernel.

  1. netstat -a -o -n -b | findstr :80

  1. tasklist

Sorry, I don’t know why this problem occurs? How to solve it.

you cannot just change port 80 to something else.
Seems you running docker rootless, so it does not have permission to listen on port 80.
you need to fix that, or if you have a public IP address for the server, you could use the docker compose file, with letsencrypt HTTP01 challenges ( is explained in the file )
Or if you have complete control over your public DNS and is hosted on a supported DNS provider, you could look at the DNS01 example docker file i added

Anyway, thank you very much @ Allan.

Here is a solution to this problem (http error 404), hoping to be helpful to other users who encounter this problem.

Prohibit port 80, HTTP service method:

Try the following steps to resolve the issue:

  1. Open Command Prompt.
  2. Run net stop http.
  3. Press Y to confirm (if prompted).
  4. Run sc config http start= disabled.
  5. Restart your computer.

This should disable the HTTP service and free up port 80.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.