Nodered Agent not working

Hi @Allan_Zimmermann .
My nodered agent is not working today. i do alot of troubleshooting i.e. Restart agent , Delete agent . After deleting agent when i create a new agent then still getting this “Bad gateway error”.
FYI openflow is setup on my server.
Please help me.

what is the error inside the agent ?

docker compose logs insert-agent-name-here

i have to pass the whole url of the agent . My agent is this “”.

“docker compose logs”. this is not actual domain it’s an example

is above correct ?

No, just the “slug” name, so in your case

docker compose logs winter-surf-f40a

getting this “no configuration file provided: not found”.
But i have the agent . You can check

are you running the command on the server, from the same directory as the docker-compose file ?
Can you see if if you run docker ps what if you use docker compose logs ?

If i run docker ps command then i see the output but when i run the docker compose logs then same error appear i.e. "no configuration file provided: not found "

did you install openflow ? are you responsible for this docker installation ?

Yes @Allan_Zimmermann i found the directory but when i run this command "docker compose logs winter-surf-f40a " this error occurs : - no such service: winter-surf-f40a

Yes i install . It runs very smoothly . i am using this from last 1 month. But today i am facing this type of problem

I’m sorry, you are right, docker compose cannot see the agent’s …

First do

docker ps --format 'table\t{{.ID}}\t{{.Image}}\t{{.Names}}'

Look for the one with name winter-surf-f40a
copy the ID and then do

docker logs insert-id-here

But i think i know what is wrong, I get an error too, so let me just quickly see if i can make a new image with a fix to the error I’m seeing …

@bpin i think maybe this is related ?
There is a bug in my nodered image ( i working on a fix right now )
Maybe this was what you had issues with too ?

@Allan_Zimmermann . Thanks for your quick response.
Please let me know what to do next. Actually today i have meeting with client and i have to show the process.

Ok, new image pushed
Go to openflow and click stop, then click play

1 Like

Thanks @Allan_Zimmermann . For helping me now it’s working fine .
BTW what was the issue ?

An update for openflow 1.5.1 broke how it works with 1.5.0 ( find the open id connect information )
But was easy to fix
I always test in kubernetes, but forgot to test with docker too.

Ok ok. But again big thanks for your suppot :slightly_smiling_face:

Hurrah ! It’s running - well done - goodness knows what type of mess is left in the git trail, but it is indeed running. Thanks Allan !

(The screen is after selecting Agents)
I just tried adding the agent, then stopping and starting. It started running straight away.
Now I just need to work out how to use it …

Glad it works for both of you again.
Sorry about that, i normally make sure to keep :edge and :latest seperate, but the updates i made was important for both releases.

It’s ok @Allan_Zimmermann .
Sometime these kind of things happens. But we are lucky that we found a guy like you. Who are always ready to help us. You are such a nice guy.
Once again Thanks @Allan_Zimmermann

1 Like