Login SAP Activity can't reach the Host

Hi @Allan_Zimmermann , i following your video on YouTube about “Get a good start with SAP in OpenRPA” but when i tried the “Login SAP” activity, it always pop up error like this :

“partner “192.168.x.x:sapdp00” not reached WSAEWOULDBLOCK : Resource temporaly unavailable.”

I’ve already turn on the “Enable Scripting” on SAP options btw… And what is sapdp00 mean?

Have a solution about it?


WSAEWOULDBLOCK means the server is not responding.
if you want to use service names instead of ports ( the sapdp00 ) then you need to make sure it exists in your services file ( C:\WIndows\System32\Drivers\Etc\services )

Sorry for my late respon, thanks for the reply @Allan_Zimmermann
I had checked services file and the sapdp00 was already added automatically when I install SAP. But, it’s still not working when I do Login SAP (with OpenRPA).

Of course i do login manually to the server, and it worked.

Maybe there are rules i missed? Thanks

I have had to help a few people with the connection string, and I always end up spending waaayyyy to much time googling “sap connecting string” … I normally find one that works, but yesterday i had a meeting with someone where i had to give up. OpenRPA uses “Application.OpenConnectionByConnectionString”
The offcial doc point’s to this page Route Strings (SAP Library - SAProuter)
This page also have some examples
SAP Help Portal
And here is more details about using routers
Route String Entry for SAProuter (SAP Library - SAProuter)
Hopefully, one of these resources will provide the breakthrough you need.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.