Java selector is not returning all the columns from the Oracle ERP application grid

OpenRPA version: 1.4.49
OpenFlow version: 1.4.36
Using or self hosted openflow: self-hosted
Error message:OpenRPA.JAVA activity returns only first 10 columns from Oracle ERP JAVA application, it’s not detecting other columns in selectors
Screenshot or video:

Attach a simple workflow from OpenRPA or NodeRED that reproduces the error/issue:

I have tried to modify the max results from the below method, still it’s not working

private void Open_Selector_Click(object sender, RoutedEventArgs e)
            string SelectorString = plugin.Selector;
            Interfaces.Selector.SelectorWindow selectors;
            if (!string.IsNullOrEmpty(SelectorString))
                var selector = new JavaSelector(SelectorString);
                selectors = new Interfaces.Selector.SelectorWindow("Java", selector, null, 20);//modified from 10 to 20 - not working
                var selector = new JavaSelector("[{Selector: 'Java'}]");
                selectors = new Interfaces.Selector.SelectorWindow("Java", selector, null, 20);//modified from 10 to 20 - not working
            // selectors.Owner = GenericTools.MainWindow;  -- Locks up and never returns ?
            if (selectors.ShowDialog() == true)
                plugin.Selector = selectors.vm.json;

from the screenshot i does not look like you have much more than 10 rows.
if “endless scrolling” is implemented in the java application you need to scroll down, to get more loaded. Get Element will not do that for you-

HI @Allan_Zimmermann , thanks for the prompt response. The issue is with the Columns.
For the fist 10 columns it’s returning all 4 rows. Whereas starting from 11th Column it’s not displaying anything in the selector scroll view,

Sorry, i didn’t read it properly. I see now you did write columns.

Yeah, that is a little strange, if you move sideway in the UI, can you then see them in openrpa ( after closing and re-opening the selector window ) ?

Thanks, I’ll try and let you know.

Hi @Allan_Zimmermann , I have tried scrolling and then select the element, still it’s not returning the columns from 11th position…

Well, the scroll bar seem to suggest that all columns are loaded ( and therefor in the ui tree ) but i was hoping maybe there was some “lazy” loading going on, to have an easy solution.
Then I don’t know what the problem is, if you build your own version of openrpa, and update SelectorWindow function to load more than 10
If you mouse over, does it find the elements ( with recorder overlay enabled ? )
It should not affect recording, or finding stuff, the 10 limit was only to avoid “hanging” the selector windows with loading way way way to many objects

Hi @Allan_Zimmermann , Thanks for the response.
I’m not using own version of openrpa, just tried to modify the maxresult and validate.

  • If mouse over, does it find the elements (with recorder overlay enabled?) - Not Working

Please help to get some workaround.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.