Issue Python 3.11 (strange behaviour)

Hi @Allan_Zimmermann

I have updated openrpa for a recent pre-release version, where was included python 3.11but for some reason when I run any “pip command” this message is displayed:

Could not find platform dependent libraries <exec_prefix>

And some times ii break the execution of wrkflows thta use python (invoke code activity).
Can you help me figure out what’s happening?

I never code in python, so I’m not sure what that could be.
maybe some of the more python users have an idea

If you have more than 1 python installation on you system, this error occurs when pip is not pointing to the correct installation.
You can also check the PATH environment variable(s) on you system. Make sure Python related paths are pointing to the correct folders.

1 Like

You can try this with command prompt instead “pip command”

C:\yourpath\AppData\Local\python-3.11.0-embed-amd64\Scripts>pip install xxxxxx

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Hello @UnyBots,

I’m not sure if this is still relevant to you or if anyone else is facing similar issues, but I recently faced this warning on a new Windows server where I had only installed the embedded Python via OpenRPA. It appears that some libraries were missing, and I found a solution that worked for me. I replaced the embedded Python with a new and compatible version located at: C:\Users\[your_user]\AppData\Local\python-3.11.0-embed-amd64.

Please follow these steps:

  1. Download the python-3.11.0-embed-amd64.zip release.
  2. Back up the folder named python-3.11.0-embed-amd64 created by OpenRPA, and then replace it with the new python-3.11.0-embed-amd64 from GitHub.
  3. Inside the new Python folder, run the following command: python.exe -m pip install --upgrade pip.
  4. Test if it works by running the following command: python.exe -m pip install numpy.

By following these steps, your OpenRPA setup should work smoothly. I hope this solution helps!

3 Likes