ID token not issued by expected OpenID provider

Hi @Allan_Zimmermann ,

I am not able to setup nodered. i think the issue is the nodered agent is not getting registered into same project. Please help , i need to setup asap for client .
image (3)

this looks like the samme isue repported here

Can you supply the same information ? ( look at console output of nodered package to see if there is any errors ? NOT the cannot convert undefined or null to object message, that is irrelevant to the issue )

Hii I am also facing the same issue.
I have setup the whole thing, but nodered agent is giving this error.

that is 3 people with this issue now.
I’m working on one person’s setup that is failing, to is trying and figure out why this is happening ( and why i cannot reproduce it myself )
I will post here, when i find the solution

Thanks for your response.
Looking forward for the fix.

I cannot for the life of me see why this would happen.
So the “latest” image that was supposed to be version 1.5.3-19 was broken. Funny enough, using 1.5.3-19 as tag worked.
I always test by using version number tags since you cannot always be sure what version you are on, when using :edge or :latest tag. that is why i never caught it.

Anyway, to ensure everything works, i have now pushed a new image.
First stop all agents.
Then stop and remove openiap

docker compose down
# or
# or whatever you are using in your setup 

now we purge the docker cache

docker system prune -af

start openiap again

docker compose up -d
# or
# or whatever you are using in your setup 

# and then pull the images to avoid the "image not found" error
docker pull openiap/noderedagent
docker pull openiap/nodeagent

Still I am not able to make it work.

Check this out. May be it would be helpfull in fixing.

Try going to Entities, select config collection, and look for Base configuration or any object with _type config
Is there more than one? Then find the “best” one and delete the rest. There should only be one

Done that. But still not. I have tried multiple times.

Logs of nodered agent

I have tried with latest tag images and as you told to use previous tag.
Still I am not able to get it running.

if you can get me ssh access to the machine and an admin login to the openflow, i don’t mind having a quick look

Can you pls provide me your email so that I can share details over there.

you can send it here

Kindly Check Mail. I have shared the details.
Thanks for your support.

Took forever to get access to a machine that can run teamviewer
But multiple times when testing your server was down
I suspect this is not a server, but a client computer ?
It’s down again now …

Actually, We are on different time zones. So, can you please tell me a particular time when you are available so that I can provide proper access. It would be much appreciated.

it’s still offline.
you can see my free times here.

I am sharing details now. kindly check mail