Huge OpenRPA memory

Continuing the discussion from OpenRPA Using too much memory:

OpenRPA version:
OpenFlow version:
Using or self hosted openflow:
Error message:
Screenshot or video:
Attach a simple workflow from OpenRPA or NodeRED that reproduces the error/issue:

Today I was running the bot on unattended basis. it was running for almost 2-3 hours and suddenly it stops processing item.when I check OpenRPA was not responding and it was using 11.8 GB of RAM

Was any workflow designer open ? if so, then please make sure to close those.
If not, then update OpenRPA to latest version, and next time it happens create a memory dump and upload it to google drive and send me a link, then I will tell you what was using the memory.

It is happening again here is the link openRPA
Here is the link of memory dump

I give up, i cannot work with a file that big.
My virtual windows machine crashes when ever i try to download it
Please make a dump before it gets so big. Then I’ll be happy to see if i can help you find what is using all the memory, but 99% of the time it’s due to datatable being used as argument between workflows with invoke openrpa… ( for instance, if you send a datarow, the object still reference the datatable, and sends everything )

I changed bot to run only for 3 transactions however it is getting stuck and in transaction data there are only 2-3 small data tables. Here is the new file which of 4 GB instead of 32 GB openRPA

1 Like

I havent checked the new one ( did you remember to upgrade ? )
But I managed to get the big file transfered into my dev machine.
I have never seen this kind of usage before, for some strage reason i cannot see the type of data that is being keept in the variables, but i can see it is variables/arguments …
So you are doing something in your code that builds up a lot of data that is not getting released

One thing, that strikes me is, openrpa keep the state ( and there for all variables/arguments ) in memory for up to 15 minutes after the workflow run. ( until it has successfully saved the state to the local database and openflow )
So you could try disabling state complete and see if that changes anything
close openrpa, and modify settings.json with
set disable_instance_store to true
set skip_online_state to true

Same thig is happening again…
There is something wrong with the sharepoint/onedrive page. Chrome hangs/crashes as soon as i try to download from there, from windows.
Can you please use google drive instead. ( that is what I’m doing, i download the file, zip it, and upload to google )

Thank you Allan for your support let me upload file to google drive instead

no no, just the “next one” if we/I need more. I have the two once’s in there already :slight_smile:

You mean update openRPA to latest version?

Yes, I only keep symbol files for latest build, so i cannot relate anything in the dump to my source code, unless you are on the latest (pre release if that it the newest) release on github.

In the smaller dump it looks like you have the designer open … please do not open the designer if we are searching for a memory leak. Half of the memory usage is from one or more designers being open ( or having been open, it memory leaks like crazy nothing i can do about that, so do not open them )

Anyway for now, let’s see if disabling state helps.

It is still happening I have recorded video also where set disable_instance_store is true and
set skip_online_state is also true and bot is running as an agent. but RAM memory is increasing drastically ScreenRecorderProject7.mkv - Google Drive

Found out the bug in my code seems like in state machine there were 3 out condition it was not matching any of 3 condition and because of that it was stuck. Really Appreciate your help on this

1 Like

glad you found the issue

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.