How to configure proxy in openflow?

Hello, first of all: Allan Zimmermann congratulation on creating this amazing platform (OON), really great product.

I’m trying to configure proxy in openFlow but it keep displaying the page below, when trying to access:

I have installed openflow via docker and works perfectly outside our “proxy server” but when I connect to our internal network show me the “Network Access Message”, and I have followed the url provided in the openflow documentation and added the “environment variable” in my machine and the variables to the docker-compose but the problem persists.

When behind a proxy server | openflow.

Can you give me more details on how to do the proxy configs ou is there another why to do this configs?

you cannot use though an proxy server, that is ONLY for using on the local machine.
you need to setup your own dns to access it from another machine.
Now i see your using ISA/TMG server, this will allow you to point dns to the tmg and then forward using IP but override host header.
I worked a lot with TMG back in 2010/2011’ish and back then it did not support websockets ( and openflow requires websocket support) , I see it has been update up til 2014 so i don’t know if it works now.

1 Like

Ok… you right. I see that the url is pointing to, I will install it in a server and setup the own dns.
Just a silly question: why that openflow need to connect to, besides the “function” of connecting to openrpa, does it have any other function? :thinking:

it does not.When using docker traefik listens on port 80 or 443 and needs to know where to send the trafik. It does that by looking at the host name ( just as you would do in a HTTP listener on tmg )
By default it uses since that also works with so you can test different services. Once you need to use this from other machines you need to setup your own dns using the guide at GitHub - open-rpa/docker and update the docker compose file accordingly

1 Like

@Allan_Zimmermann, thank you for the clarification. Unfortunatly I have access only to a server with Windows Server 2012 R2 and it’s not possible (for my knoledge) install or run docker.

For now I’ll use openflow locally until I found some solution for my server situation.
Once again thanks.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.