How add my proxy in node-red agent?

Hi all.
I encountered this problem - when I pass proxy parameters to the openflow container, the container with node-red ignores the passed parameter. Please help me with this issue. Thank you very much!

How did you pass it ?
What did you pass ?
How do you test it ?
What error are you getting ?

I am passing environment in docker-compose file like :


Then I restart docker-compose.
In OpenFlow I check that the enviroments have been transferred. Further creating a new Node-red agent and trying to install new palettes. And when I try to access I get the error “failed to load node catalogue”

I also tried to separately pass all the parameters to config in Openflow, but nothing worked.

hmm, that seems correct.
Normally people get issues when using * or use the wrong “casing” ( upper/lower case )
Just to test, if you add a HTTP request node and do the request does it work then ?


Judging by your screen, I didn’t quite understand where to connect the proxy…
So far I have found that for some reason new environments from docker-compose are not being migrated to node-red containers.
Regarding checking the directory availability through a proxy, I had to do the following: 1) go into the container with the node-red agent
2) manually export proxy settings
3) then used “wget” and got an Index.html file with the correct answer.
But at the same time, this node-red agent setting has not been changed and when trying to request a directory, the same error appears.

I am having a little problems probably understanding what you mean. Sorry about that.
What does “new environments from docker-compose are not being migrated to node-red containers” mean ?

When you add agent_HTTP_PROXY and agent_HTTPS_PROXY to the api container, this tell openflow to add a HTTP_PROXY and HTTPS_PROXY to new agents getting created. Then it’s up to the different application to read and use those. That is “out of my control”.
But npm does not respect those, so to fix installing packages the nodered agent code, will create an .npmrc file that contains the proxy information, but that is not relevant for doing web request from nodered it self.
Moreover, the HTTP request node has a check mark you need to enable to make it use the proxy setting ( the screenshot ) so if you are having issue with the http requests from nodered, make sure that is set.
You reference … this is something the client does, ( you browser ) it has nothing to do with the nodered container, the web browser dies a request to that url and uses the response to generate a list of modules you can install.

Thank you very much, your last comment helped a lot in solving the problem. My mistake is that I thought to display the directory you need to forward a proxy inside the node-red container. After I added a proxy on my browser, the list loaded!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.