Error Ïnstalling OpenFlow using Docker

I tried installing using docker but getting error ''WebSocketClient.js:2 WebSocket connection to ‘ws://’ failed.

I followed following steps:

  1. Added A and CNAME records in GoDaddy.
  2. Ping is working fine => ping
  3. git clone GitHub - open-rpa/docker
    cd docker
  4. docker-compose.yml => Replace 4 occurrences of “” with “
  5. Run command => docker-compose -f docker-compose.yml up
  6. Open URL in browser. Page blank and gives error on console => WebSocket connection to ‘ws://’ failed

Please suggest what I am missing.

Not sure what I am missing here. any help?


The ws url is constructed out of domain + protocol environment variable or can be overridden by api_ws_url

There used to be an “domain” variale in the docker compose file. I must have removed that while cleaning up" and that is why you are having issues.
Simply add


around line 71 ( services → api → environment )

I have re-added the domain environment variable to the docker compose files in the repo

Thanks. I did the change. But now getting new error. 502 (Bad Gateway)

Ping to is giving result.

ping is irrelevant

what does the log’s say ?
any errors in traefik or api logs ?

How can I check error in traefik and api logs


docker compose logs

or in your case

docker-compose -f docker-compose.yml logs

Here is the downloaded log but I cant spot any error.

If you can point out that will be super helpful.
Thank Allan

Try running up again. Sometimes rabbitmq,takes to long to startup

I did as you said and its working now. Thank you so much.
Now how do I start Node-red?

The menu go to agents

Tried adding Node-Red Agent but getting error.
(HTTP code 404) no such container - No such image: openiap/noderedagent:latest

Yes, will take a little time before docker is done downloading it

Ok. I will wait and let you know how it goes. Thanks

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.