Error in MongoDB - Docker

Hi @Allan_Zimmermann ,

Good Day!

I did installed OpenFlow using docker on Ubuntu, Currently I’m facing Issue On MongoDB, this is a blocker for me to explore further, Would be great If you could help assist on this case.

Log Command : docker-compose -f docker-compose.yml logs
Error Message :
docker-mongodb-1 | {“t”:{“$date”:“2023-12-21T11:34:56.003+00:00”},“s”:“W”, “c”:“QUERY”, “id”:23799, “ctx”:“ftdc”,“msg”:“Aggregate command executor error”,“attr”:{“error”:{“code”:26,“codeName”:“NamespaceNotFound”,“errmsg”:“Unable to retrieve storageStats in $collStats stage :: caused by :: Collection [] not found.”},“stats”:{},“cmd”:{“aggregate”:“”,“cursor”:{},“pipeline”:[{“$collStats”:{“storageStats”:{“waitForLock”:false,“numericOnly”:true}}}],“$db”:“local”}}}
docker-mongodb-1 | {“t”:{“$date”:“2023-12-21T11:34:56.319+00:00”},“s”:“I”, “c”:“CONTROL”, “id”:23377, “ctx”:“SignalHandler”,“msg”:“Received signal”,“attr”:{“signal”:15,“error”:“Terminated”}}

Log Command : docker logs demo-mongosetup-1
Error Message :
MongoServerSelectionError: connect EHOSTUNREACH 17*.**..:27017
Current Mongosh Log ID: 658541c75a6ab4d1ea0e905d
Connecting to: mongodb://mongodb:27017/?directConnection=true&appName=mongosh+2.1.1

Your prompt assistance would really valued.

OpenFlow OpenRPA #mongodb

Thanks in advance

Hi @Allan_Zimmermann ,

I’m just follows up the above case. this is a blocker for us right now, your assistance on this matter would really helps us to explore further.

For more info attaching new case for your reference - link

Thanks in advance


docker-compose -f docker-compose.yml down

then docker ps and remove everything that could be interfering and try again ?
When running

docker-compose -f docker-compose.yml up

run it twice with 10 seconds in between, rabbitmq often takes to long to start so the api does not come up.
Please don’t post logs from docker and ask us to see what is wrong. Use ChatGPT or similar for that.

@Allan_Zimmermann - Thanks for the response. We have tried the steps mentioned above. Still facing the same issue.

I’ve tried reinstalled the openflow instance from scratch using docker.

@all - I would appreciate if any other experts on this forum could assist on this case.

++ @yashshah

Thanks in advance

If you are willing to pay, you can always try contacting an expert from the list.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.