Error CS1704 in invokeCode

hey, i used invokecode with C# and when i run my process it stops with this error : # error CS1704: An assembly with the same simple name ‘Python.Runtime, Version=, Culture=neutral, PublicKeyToken=null’ has already been imported. Try removing one of the references or sign them to enable side-by-side.

try removing the namespace ( under namespaces )
you need to open invoke code, and close it and then close/re open the designer to make it take effect ( yes, stupid … )

You mean that i need to open/close invoke code and then open/close the workflow ? if so i did it and i still get the error

did you remove the namespace first ?

More techincal:
When you “open” invoke code, and select c#/vb it will copy the list of namespaces added to the designer, to the invoke code as a hidden property … the list of namespaces get geneated when you open the designer, that is why you need to close and open it again, after removing the namespaces. Then opening invoke code, will update the hidden list of namespaces and it should work.

No i did not remove the namespace, i’m sorry but can you give more details about how i can remove them (steps)

if you are talking about namespaces related to invoke code in the XAML file, i did remove them but i still face the same problem

This is the version that is bundled with “latest” release of openrpa.
If i google this, it seems this error comes from having 2 versions of a dll, that both have the same name and version. ( a file compiled and build to be the same version and name, but saved with different file names )
The only way I can think of that, happening is if you somehow installed the same dll using package manage as well, can you check if you have a folder called extensions inside the OpenRPA folder inside my documents ? if so, does it contain a Python.Runtime.dll file ( or anything else related to python )
If not, then maybe something has gone wrong with the installation files, then try uninstalling openrpa, if C:\Program Files\OpenRPA exists after uninstalling, delete the folder, then reinstall and see if that fixes the issue.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.