Custom browser for "OpenURL"


OpenURL has three parameters defining browser for use (“edge”, “ff”, “chrome”).
Can be defined “custom browser” like “portable waterfox” or other “portable” and isolated from OS browser?

Often used for dedicated environment only for scripts/robots.

Kind regards,

The whole point of creating a browser extension instead of using webdriver was to allow for better developer experience and allow for attended robotics.
So if what you want is unattended robots, then you need to run it in a dedicated environment ( not your own desktop, in that cases it not unattended any more ) that mean run in the console of another pc/server or use hd robots or for those rare cases where you don’t have access to that, you can use Child Sessions. But then you need to create a separate chrome profile for the robot if you want to use chrome while the robot is also using it, since chrome cannot handle multiple sessions at the same time. ( replace chrome with = chrome/edge/firefox )

Hi Allan,

“and allow for attended robotics”
Yes, I also want to provide such kind of gui script (attended), but my additional constraint is, that I am working in the corporate, “standardized” environment and all three browsers are provided/configured centrally. For specific works as “attended robot”, I have to use “portable” browsers, so that avoid interference with global settings and personal work/environment. I am not allowed to have local (OS) user and run it (Child Session?) as “robot” environment. I did not find “OpenURL” option to define different browser profile.

I also tried to use “OpenApplication”, but I stuck on the very common for RPA world problem, how to send “enter” key after place url in the browser navigation field :wink: Yes, this is my mind constraint, as I fixed on the imitation of a manual activities. I found a workaround which use “click” only… :wink:

Now I have a weak hope to fight with BMS Remedy… :wink:

But “enter” is mentally easer… :wink:

Kind regards,

There only 6 propertys on open url and 2 of have UserData in their name. They work just like in most other rpa tools ( uipath has a good explanation here )
Automating a browser using windows components is going to be pure hell and you will get best results with IE. For chrome you need to launch chrome with --force-renderer-accessibility
To send enter, you first need to ensure the field you want to send enter has focus and then use “type text” to send it … press record, press enter, press escape to see how that works or use {enter} for more generic solution ( see syntax here )
If you cannot install the browser extension, then OpenRPA might not be the right solution for you. You can use puppeteer in openflow or look at other RPA tools that use webdriver like TagUI

Hi, Allan,

Unfortunately, my workaround has not work till now.
I tried to use browser buttons to reach the page, but the second “click” (first is “View site information”, “magnifier”) on the “Go to the address in the Location Bar” (“grey arrow”) .
does not work (does nothing?). I have to make two “clicks” as “grey arrow” is dynamic and not always visible.

Kind regards,

Selector for “grey arrow”

“filename”: “C:\Roboczy\toolsPortable\waterfox\WaterfoxPortable\App\waterfox\waterfox.exe”,
“processname”: “waterfox”,
“arguments”: null,
“Selector”: “Windows”,
“search_descendants”: “True”,
“mouse_over_search”: “False”
“ClassName”: “MozillaWindowClass”,
“Name”: “Waterfox”,
“ControlType”: “Window”,
“FrameworkId”: “Win32”
“Name”: “Navigation”,
“ControlType”: “ToolBar”

Can it find it, if you click highlight ? If so, then try using physical clicks ( set virtual to false )
Also, the selector you sent does not seem to find the individual element but is finding the toolbar it self.
If the developers disable access for windows automation, you can either try using coordinates ( require that the application always has the same size ) or use image recognition ( you can “mix” those, like usin windows Get Element to find tool bar and then use a nested get element from images to limit the search area

Hi Allan,

This element “Go to” is dynamic and visible only when application has a focus and address field is edited.
For is the reason it is quite easy to record it, but highlight is not able to find it. But the recording is also not complete, as it recognize it as whole toolBar. As stated in “selector”. Waterfox is a clone of the Firefox and FF has the same element.

For the same reason “Get element” does not work. When tried to “highlight” element from Designer, it find the images gathered in… Designer. WF has not a focus and element is not visible. When run a flow and element is visible, it also is not accessible (Failed to find item). Even I nested activities inside “Open Application”, WF has a focus and element is on the screen.

Also both experiments with “Send Text” and “{ENTER}” and proper recording of the set address action (double “enter”, for url text assign and run call) has no expected results neither.

I think my workaround must be simplier and just choose a bookmark with url.

Thank you a lot, Allan. If you would have some time for this “dynamic element”, it would be very valuable.

Kind regards,

Hi Allan,

I convinced my “standardization council” to allow openRPA exist in company standard environment.
For now “Open URL” is for me in a FF, which I have on my box.

I hope, will be easer.

Kind regards,

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.