Conflict RPA schedule (Robot node going to timeout instead of wait)

Hi all, i have some issues with scheduling my robot using NodeRed. Lets say i have 2 robot (robot_A and robot_B):

  1. if the robot_A is in the middle of working (idle state),
  2. then the robot_B triggered in my shedule with cron node.
  3. then the robot_B throw error and get timeout status.

what should i do if i want to add the robot B to queue job/ task instead of timeout? I don’t know how long the robot_A needed to completed the job/ task.
should i built HD robot? or any nodered module to solve this problem

robot_b should not timeout, just because robot_a is running a workflow.
I can think of 2 problems here. If neither is your use-case, then I am sorry for the long text. Then please add more details on how/when/why you are getting a timeout.

  1. You are using the same username for both robots. That is not allowed, each robot must run as a different user
  2. You are mixing up names. Sometimes people using UiPath calls a workflow/project a robot, that makes things super confusing. So if you do not have 2 robots, but you have 2 workflows on 1 robot. Then yes, workflow 2 will timeout


  1. for 1, there is no solution, except making sure both robots are using different users.
  2. If you want to run multiple robots, remotely on a robot, you can either mark one of the workflows as a background workflow, or you can update settings.json to allow running multiple workflows, by setting remote_allow_multiple_running to true and remote_allow_multiple_running_max to the max number of workflows.

When OpenRPA gets asked to run a workflow, it checks if any workflow is already running, and if it is, it’s refuses to run the workflow. This is due to the fact you cannot do 2 different things in the same UI, that makes no sense.
But if have a workflow that is not using the UI, you potentially could run it multiple times, so if you know that is the case, you can mark a workflow as background, and then it will not “count” as running when triggering remotely.
If you simply do not care, and are sure you know what you are doing and is 100% sure there will never be UI conflicts between workflows, you can also enable remote_allow_multiple_running then OpenRPA will allow more than workflow to run, no matter what. Normally this is something you only enable on robots that is not used for RPA.

1 Like

Thanks for the solution Allan,
solution number 2 works for me.
All robots run the workflow as a background, so they are not using UI at all. I have enable “remote_allow_multiple_running” then it works perfectly.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.