Centralized Workflow Not Reflected to OpenRPA Clients

Hi! Please help,
I have set up a local OpenFlow with several OpenRPA clients connected to it. It also shows “Connected to [ws://openflow] as [user]” below the OpenRPA window. But when I update my workflow as the admin, the clients (users) don’t upgrade their individual workflows, even though the workflow’s user group permission is set to :heavy_check_mark:Read :heavy_check_mark:Invoke.

I also see the updated workflow in the OpenFlow Webpage under Robot Workflows but it is not reflected to individual clients

Found a workaround: I tried to close OpenRPA then rename the C:\users\user\documents\OpenRPA\[Hostname].db and [Hostname]-log.db then open the OpenRPA again and it now updates accordingly to the OpenFlow admin.
Please help me understand why and is that workaround correct?

Everything in OpenFlow depends on change stream’s in MongoDB ( i call it watch’es )
Those are only available when running in a replicate set. So if you only have a single mongodb instance not configred in a replica set, nodered and openrpa clients will check for updates at intervals ( i think it’s 5 minute for openrpa by default )
You can force an update in OpenRPA by clicking the big refresh icon

There are two example on how to setup a replicaset in the docker repo ( File Finder · GitHub and docker-compose-traefik-offline.yml )
make sure to take a backup BEFORE you try anything.

Hi Allan,
Thanks for the usual support.

I’m just wondering, in my case, it was already past several hours but still, the update didn’t reflect on the clients, and also, I tried clicking the big refresh button that you mentioned, but it still didn’t reflect.

It just reflected when I did the renaming or deletion of C:\users\user\documents\OpenRPA[Hostname].db and [Hostname]-log.db then opening up the OpenRPA Client again

That is not suppose to be like that, that could be a bug. But without a way for me to reproduce it there is not much I can do right now.