Agent no longer running

I’m now using the image you had recommended before in this thread:

But unfortunately, now doesn’t seem to execute on its own. When I check the logging when running it on our openiap instance this is the log:

I’ve ran the same package on my own machine using the assistant program and it ran without issues.

important information

before the weekend, you would need to either

  1. select the package ( if it has daemon set to true in package.json ) on the agent page
  2. select it to be run as part of a workitem queue ( edit queue, select agent and package )
  3. run it your self, by sending a commend to the agent queue
    ( you can test that by clicking
    next to the agent on the agent’s page

After this weekend, once you get updated to latest version, number 1) above changes abit
This has moved to schedule’s section on the edit agent page
For deamons packages you can just schedule it ( meaning it will run it at startup and if it crashes it will retry it 5 times and then give up )
For non deamons packages you can setup a chron schedule for when to run it
( so if you want to run somethign at intervals, a workitem queue is a bad idea, and having to run a nodered/other agent to send messages seems stupid … so now we can shedule running packages instead )
So if I want to run my package every 5 minutes i can add it like this

Back to you question

So did you select the package when you added the agent ?
Looking at the console output it looks like it was not told to run any package

I just noticed you are from twiki …
I have just had a look, you forgot to enable it

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.