Unable to spy elements in openrpa

Hi @Allan_Zimmermann I am not able to spy the elemrnt in openrpa. I have added the extension in chrome, as well as in edge browser. In the openrpa it is displaying as NM: offline. Please help me with the issue.

Please find the attached screenshot for your reference.

It will only show online, if the browser is started, the extension has been installed and chrome has successfully started the OpenRPA.NativeMessagingHost.exe

Is chrome running ?
Is the openrpa extension loaded ?
Is OpenRPA.NativeMessagingHost.exe running ( check taskmanager under details )

Chrome is running, extension is enabled, but OpenRPA.NativeMessagingHost.exe is not running

if you run i manually, does it show any errors ?

Is the extension registered correctly ?
Open regedit and check


this should have a default key pointing to chromemanifest.json in the openrp folder

Open the file, and make sure the path to OpenRPA.NativeMessagingHost.exe

Lastly make sure you have the correct extension installed by trying to open


this id hpnihnhlcnfejboocnckgchjdofeaphe should also be in the chromemanifest.json file

all the thing are mapped correctly

open chrome://extensions/
enable Developer mode
Is openrpa running ?
( must be
and not
does it have any errors listed ?
if you open the service worker, is there any errors ?

The window has warnings in service worker

Then I’m out of idears …
you need to figure out why OpenRPA.NativeMessagingHost.exe is not starting.
Check the event log, ask you IT department if there is any policies for chrome or windows that could block it, etc.

Thank you very much for your support Allan, I will research on it. I am using my personal laptop.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.