Cast not valid error and crash openrpa

Hi, sorry but i have a problem: today i have a modified an automation with new xpath in get element and save all. After, to run, i encountered an error it said: " error click focus something" and then i have a installed new version OpenRpa. But at the opening of openRpa, i have a error “cast not valid”. I try to automation and create new and every time to crash. Especially if I try to put any breakpoint. I try to installed with repair, new version again and reloaded worflow but don’t resolve nothing. You can helping? i think is something in the database when I saved the change. Because openRpa is in several of my machines connected to a database. Only program , in machine different, is a have same problem. If create new workflow i have error “invalid lengh for a base 64 char array or string” in output tab.

If your robot is connected to an openflow installation you can simply delete the .db file.
Close OpenRPA. Open “My Documents\OpenRPA” and rename all files with the name if your openflow to .old ( if you are using the default openflow of then rename to ) and then try starting openrpa again, it will re-download all flows into a new .db file

thanks, it worked! i renamed db in db.old in only machine where openrpa and, restarting, everything worked again

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.